Completix - Completix Website is Operational – Incident details
All systems operational
Completix Website is Operational
Resolved
Partial outage
Started 6 days agoLasted 2 minutes
Affected
Website
Operational from 6:59 AM to 6:59 AM, Partial outage from 6:59 AM to 7:01 AM
Updates
Resolved
Resolved
This incident has been resolved.
Investigating
Investigating
We are currently experiencing an outage with our website and we are currently investigating this incident. You can still login to the App with the direct link